Jump to content
DeployCentral
SteveE

Windows App (Calculator) stops working after re-image

Recommended Posts

I am at my wits' end right now!  I have been messing around with this and trying so many different things to get this to work, but no dice.  After deploying an image to a computer, users are unable to open the calculator app.  This is kind of a big deal for them. I've been Googling all day and tried it all.  I've mostly been concentrating on figuring out how to get it to work post-deployment.  For local and domain administrator accounts I can run a Powershell script to make it work - for that user only.  It doesn't fix it for all the users of the computer.

If anyone has run into this and has a way to resolve the problem, please let me know!  I could really use some help here.

Screen.JPG.ef75ad7f4a91c6ed0edf72e765b61b1c.JPG

Share this post


Link to post
Share on other sites

We have seen issues with Windows 10 v1709 Store appx packages (and the Windows Store itself) not functioning after deployment.

The first thing we recommend is that you try to fix your current VM. Power on your reference VM, launch the Windows Store, and install all available app updates. Once the updates have all completed, gracefully shut down the VM (shutdown /s /t 0), then retry capture and deployment.

For some users experiencing this issue, it has resolved it. We’ve also seen success in creating a new local administrator account, or using a domain account. The process of creating a new profile allows for the Start Menu apps to re-provision. 

Unfortunately, if that does not fix the issue, the only workaround that we can recommend would be to rebuild the VM in the manner specified below.

To build a new VM and ensure that no apps are updated in the process, complete these steps:

  1. Build a brand new VM. Set the network adapter to either be disabled or not connected. 
  2. Install Windows 10 1709 from MS VL .iso (or any other official media which has not been customized for specific hardware).
  3. Go through OOBE. Once you reach the desktop, open an administrative command prompt and run the following command: 

           reg add HKLM\Software\Policies\Microsoft\WindowsStore /v AutoDownload REG_DWORD /d 2

This registry value will prevent the Windows Store apps from auto updating.  Once this is set you can open the VM settings and enable the network connection (and provide internet connectivity), then continue setting up your VM.

Once your VM is setup, do a clean shutdown (command line SHUTDOWN /S /T 0) and capture. 

You will want to add a Task to the deployment to remove the AutoDownload setting, so that the apps will update properly on the deployed device. You can add this in Deploy Wizard (or Answer File Wizard), Advanced, Tasks.  

Share this post


Link to post
Share on other sites

Hours of work went into building my reference VM.  I can't just wipe out and recreate user profiles every time I re-image a computer, that defeats the purpose of migrating the user data.  There ought to be a way to fix the profile itself without recreating it.

On a side note, I verified using a test account that wiping the profile and starting new does, in fact, fix it for that user.

Share this post


Link to post
Share on other sites

I believe the problem is related to the AppX apps and sysprep in v1709 specifically, and not the profile. Hopefully this is fixed in the next large update. We actually went through this same thing a few versions back with Windows 10. 

Share this post


Link to post
Share on other sites

Is there no work-around that you guys have discovered, aside from a user having to rebuild a profile or rebuild the image?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×