Jump to content
DeployCentral
tim.cummings@juhsd.net

Trouble Deploying Dell Latitude 7490

Recommended Posts

We recently received 10 Dell Latitude 7490, we are having trouble deploying the image on them, it cannot seem to see the SSD.  Anyone have trouble with this or resolve this before?

Share this post


Link to post
Share on other sites

If you are using SmartDeploy 2.0.2097, then you need to ensure you've built your boot media with the platform pack for this device selected.

Otherwise, if you are using SmartDeploy 2.0.3000, then it should work out of the box.

Share this post


Link to post
Share on other sites

Are you using the beta release by chance?  Can you check Add/Remove programs and verify that SmartDeplloy Enterprise is 2.0.3000.8154?  If it's not, then uninstall that version and download the current version from our website, and re-create your boot media.

If it is, then boot your 7490 to SmartDeploy and on the splash screen click Collect Logs.  Save the resulting .zip to USB or Network and email it to us at support @ smartdeploy .com

Thanks!

Share this post


Link to post
Share on other sites

It looks like the Deploy Wizard could see the disk...

DeviceID:\\.\PHYSICALDRIVE0

Caption:SK hynix SC311 SATA 256GB

So, what was the exact error you we're receiving?  It actually looks like from the logs that the deployment was successful.  Is it just that the machine is auto rebooting to the USB drive?  If so, you'll need to remove it and reboot the machine.  Or, Deploy Wizard, Advanced Options, and choose shutdown instead of reboot so that you'll know when the deployment is finished and to remove the USB stick.

Unfortunately, some UEFI devices write a firmware boot entry for the USB drive, and will try to boot to it on reboot, even if we clear out the firmware boot entries before rebooting.

Share this post


Link to post
Share on other sites

after it looks like the image loads, the computer reboots and has no bootable device other then network nic. We were using pxe by the way not a usb boot disk.

Share this post


Link to post
Share on other sites

That is probably due to a mismatch between UEFI and Legacy.  The way the machine is configured, and the boot option need to match.  I.e. if the machine is in UEFI mode, then you need to ensure you are selecting a UEFI boot menu option.  If the machine is in Legacy mode, then you have to select a Legacy option.  Ensure that once booted to SmartDeploy, the lower right hand corner shows the correct setting UEFI or BIOS.  Looks like you we're booting the machine in BIOS, but it was configured UEFI.

It looks like by default on these devices the "Enable UEFI Network Stack" isn't checked.  So, in order to UEFI PXE boot this machine, you'll need to go into the BIOS, System Configuration, Integrated NIC, and check the Enable UEFI Network Stack" option.

Also, put the machine back into it's default settings, if you changed it to Legacy...

General, Advanced Boot Options, Enable Legacy Option ROMs = unchecked

Secure Boot, Secure Boot Enable, Secure Boot Enable = checked

Share this post


Link to post
Share on other sites

They were not in UEFI mode from the factory.  I ended up factory reseting them and loading the recovery media, then install the smartdeploy agent, and deploy a package and that worked.  But I will have to test further, the image was created in a vm, so uefi or legacy shouldnt matter.

Share this post


Link to post
Share on other sites

On the F12 screen, it will say "Boot mode is set to:" either UEFI or Legacy.  Based on what that says, you have to select an option from the menu that matches, otherwise you will end up with no bootable device found.

Here is a spreadsheet we made to try and illustrate all the different scenarios and outcomes.

 

 

Share this post


Link to post
Share on other sites

I got 

Sorry, there is a problem

The page you are trying to access is not available for your account.

Error code: 2C171/1

 

when clicking that link

Share this post


Link to post
Share on other sites

Okay, I am checking now to see if this helps.  I had some techs working on this for way too long and i found they changed a lot of settings all wonky in the bios.

Share this post


Link to post
Share on other sites

Thanks for your help, with the one test machine I had it looks like not having "secure boot" enabled was causing the issue.  Not sure if it was enable or disable from dell.

Share this post


Link to post
Share on other sites
45 minutes ago, allenturnage said:

I'm currently having this same problem. I don't understand the fix here.

Are you able to enter the system settings and enable Secure Boot?

Share this post


Link to post
Share on other sites

Can you ensure you've followed this please?

 

On 2/28/2018 at 10:18 AM, SmartDeploySupport said:

That is probably due to a mismatch between UEFI and Legacy.  The way the machine is configured, and the boot option need to match.  I.e. if the machine is in UEFI mode, then you need to ensure you are selecting a UEFI boot menu option.  If the machine is in Legacy mode, then you have to select a Legacy option.  Ensure that once booted to SmartDeploy, the lower right hand corner shows the correct setting UEFI or BIOS.  Looks like you we're booting the machine in BIOS, but it was configured UEFI.

It looks like by default on these devices the "Enable UEFI Network Stack" isn't checked.  So, in order to UEFI PXE boot this machine, you'll need to go into the BIOS, System Configuration, Integrated NIC, and check the Enable UEFI Network Stack" option.

Also, put the machine back into it's default settings, if you changed it to Legacy...

General, Advanced Boot Options, Enable Legacy Option ROMs = unchecked

Secure Boot, Secure Boot Enable, Secure Boot Enable = checked

 

Share this post


Link to post
Share on other sites

Yes. I did however find the issue. My option67 in the DHCP scope was still set to work with Legacy and not UEFI. Once I changed it, it successfully booted and imaged the system and booted into Windows.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×