Jump to content
DeployCentral
Sign in to follow this  
wbeck

Unable to automate multicast

Recommended Posts

Using the Media Wizard, I build boot media and check "For use with Windows Deployment Services (WDS) multicast. And when I boot from a usb thumb drive and manually authenticate with WDS, the multicast occurs correctly and appears as a multicast transmission in WDS. However, using custom answer file to automate the entire process, I upload a boot image to our WDS. Doing a PXE boot from this boot image, I'm unable to create a multicast transmission - it just gets deployed as a normal data transmission. In other words, the image is deployed and the process is completely automated - but it does not appear as a multicast transmission in WDS. Can you tell me what's wrong with my custom answer file? Is there a switch to enable multicast transmission?

<?xml version="1.0" encoding="utf-8"?>

<smartdeploy version="1.1" version_debug="1.1.1900">

<deploy_wizard mode="Unattended">

<welcome>

<hide_options_button>false</hide_options_button>

</welcome>

<select_image>

<image_file>Z:\Images\Laptop\Laptop.wim</image_file>

<image_name>laptop</image_name>

</select_image>

<disk_options>

<!-- 0 = Recreate drives, 1 = Wipe & load drives, 2 = SmartMigrate -->

<disk_option>0</disk_option>

</disk_options>

<product_key>

<product_key/>

</product_key>

<end_user_license_agreement>

<accept_eula>false</accept_eula>

</end_user_license_agreement>

<user_information>

<full_name>Gainesville State College</full_name>

<organization_name>Gainesville State College</organization_name>

</user_information>

<regional_settings>

<time_zone>(GMT-05:00) Eastern Time (US and Canada)</time_zone>

<input_locale>English (United States)</input_locale>

</regional_settings>

<display_settings>

<resolution>Auto Detect</resolution>

<color_depth>Auto Detect</color_depth>

<refresh_rate>Auto Detect</refresh_rate>

</display_settings>

<network_tcpip_settings>

<ipv4>

<!-- 0 = Obtain an IP address automatically, 1 = Use the following IP address -->

<static>0</static>

<ip_address/>

<subnet_mask/>

<default_gateway/>

<preferred_dns_server/>

<alternate_dns_server/>

<preferred_wins_server/>

<alternate_wins_server/>

</ipv4>

</network_tcpip_settings>

<network_identification>

<computer_name/>

<!-- 0 = Domain, 1 = Workgroup -->

<membership>1</membership>

<domain/>

<organizational_unit/>

<workgroup>WORKGROUP</workgroup>

</network_identification>

<join_domain_credentials>

<username/>

<domain/>

<password/>

</join_domain_credentials>

<wds_credentials>

<server>ourserver</server>

<username>ourusername</username>

<domain>gc</domain>

<password>8DCEB88...encrypted</password>

</wds_credentials>

<summary>

<hide_export_button>false</hide_export_button>

</summary>

<completion/>

<advanced_options>

<general>

<platform_pack>Z:\Images\Laptop\Laptops.ppk</platform_pack>

<system_properties/>

</general>

<identification>

<!-- 0 = Assign a new computer name automatically, 1 = Use the following naming method -->

<naming_mode>1</naming_mode>

<naming_methods><method>WMI</method><method>EXISTING</method><method>CUSTOM</method></naming_methods>

<custom_naming_scheme></custom_naming_scheme>

<prefix></prefix>

<wmi_query>SELECT SerialNumber FROM Win32_BIOS</wmi_query>

</identification>

<migration>

<protected_folder>Backup</protected_folder>

<virtualization_platform>Microsoft Virtual PC 2007</virtualization_platform>

<create_desktop_shortcut>true</create_desktop_shortcut>

<files_to_exclude><exclude>$ntfs.log</exclude><exclude>$Recycle.Bin\*</exclude><exclude>[systemRoot]\CSC</exclude><exclude>[systemRoot]\Temp\*</exclude><exclude>hiberfil.sys</exclude><exclude>pagefile.sys</exclude><exclude>RECYCLER</exclude><exclude>System Volume Information</exclude></files_to_exclude>

</migration>

<tasks><task><phase>FIRSTBOOT</phase><command>c:\users\GSC\power.bat</command></task></tasks>

</advanced_options>

<settings>

<active_directory/>

<network_shares><network_share><local_name>Z:</local_name><remote_name>\\ourserver\reminst</remote_name><username>ourusername</username><domain>gc</domain><password>8DCEB882D0...encrypted</password></network_share></network_shares>

<proxy_server>

<proxy_server_url/>

<username/>

<password/>

</proxy_server>

<session_id/>

<unattend_delay>10</unattend_delay>

</settings>

</deploy_wizard>

</smartdeploy>

Share this post


Link to post
Share on other sites

Hi Wally,

It looks like the Deploy Wizard is having an issue reading the WDS Multicast credentials that are saved in the answer file. We are looking into the issue and will let you know when we have a work around or an update to fix it.

Thanks,

Erik

Share this post


Link to post
Share on other sites

Hi Wally,

Sorry for the delay in response, I just wanted to let you know that this has been addressed in version 1910 of SmartDeploy. Please download the update from here. This update can simply be installed over the current version. Please see this forum post for additional info on 1910.

Thanks,

Erik

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...