Jump to content
DeployCentral
tomsiemers

Enable Administrator Account missing in Answer File

Recommended Posts

I just created new answer files for Windows 7 and Windows 10. I compared them with the older ones I had been using and noticed the ENABLE_ADMINISTRATOR_ACCOUNT setting was 0 in the new files. Thinking I'd missed something I recreated the files making sure to check in the Advanced Options, but the option to enable the administrator account was missing. The version_debug setting in the new file is 2.0.3020.9142, and the old one is 2.0.3010.8834.

Has anyone else had the same experience?

 

Tom

Share this post


Link to post
Share on other sites

Hi Tom,

Thanks for reaching out, happy to explain.

This setting has been deprecated as of a few SmartDeploy versions ago. Microsoft changed the default behavior with regard to the local admin account in Windows 10, so a checkbox no longer made sense, as it would not behave in a consistent manner across different OS versions. We removed the checkbox, and now we simply check your image to see whether the VM had the local Administrator account enabled, and then we duplicate that result on the target device. If it was enabled, it will be enabled - if it was not, it will be left disabled. No action required on your part.

There is still an item for this setting in our answer files to maintain backward compatibility, but it is no longer used at deployment time. Our expectation is that this setting should not cause any problems at deployment time for you (it's been this way for a while now), but please feel free to reach out (support@smartdeploy.com) if you have any questions or issues. 

Regards,

Glenn
SmartDeploy Support

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×