Jump to content
DeployCentral
Sign in to follow this  
thosmosis

Post Image install on first login.

Recommended Posts

I have an install that runs after deployment with first login. But I want another install to happen right after that one. The single install works fine. Here's what that portion of my XML looks like.

<phase>FIRSTLOGON</phase><command>C:\Systemupdate506-01-15-2015.exe<

I have tried just adding it, but I must have something wrong...

Here's what I have tried:

<phase>FIRSTLOGON</phase><command>C:\Systemupdate506-01-15-2015.exe</phase><command>C:\logmein.msi<

And I have also tried:

<phase>FIRSTLOGON</phase><command>C:\Systemupdate506-01-15-2015.exe><phase>FIRSTLOGON</phase><command>C:\logmein.msi<

Doesn't work with my untended install from USB.

I must be missing something.

Thanks for any and all help.

Share this post


Link to post
Share on other sites

You should be able to use the Deploy Wizard to generate an answer file that has multiple tasks. If you do so, it would look like...

<tasks>
<task>
<phase>FIRSTLOGON</phase>
<command>C:\Systemupdate506-01-15-2015.exe</command>
</task>
<task>
<phase>FIRSTLOGON</phase>
<command>msiexec.exe /i C:\logmein.msi</command>
</task>
</tasks>

Need to preface the msi with the executible. Both of these would also need silent command line switches if you didn't want them to run interactively. In most Lenovo platform packs we do now try to include the ThinkVantage System Update utility. So, we can add that to a Lenovo pack if it is missing.

Share this post


Link to post
Share on other sites

Thanks for the help. I tried, and used this:

...

<phase>FIRSTLOGON</phase><command>C:
\Systemupdate506-01-15-2015.exe</command></task></tasks><phase>FIRSTLOGON</phase><command>msiexec.exe /i C:
\logmein.msi</command></tasks></tasks></advanced_options><settings>
But still not working...
Does the msiexec.exe mean that I have to find the name of the .exe within the MSI? Or did I mess something else up?

Share this post


Link to post
Share on other sites

Looks like I had:

</tasks></tasks>

Instead of

</task></task>

After <command>C:\Systemupdate506-01-15-2015.exe</command>

Works now. Thanks for the help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×