ooshnoo

unable to update the disk or filesystem boot code

9 posts in this topic

When trying to apply an image, we are getting the following error:  "unable to update the disk or filesystem boot code"

I have run diskpart on the drive to clean it, and create new partitions, but it doesn't help.

Anyone seen this before and know what to do ?

Share this post


Link to post
Share on other sites

You are receiving the following error when deploying:

 Unable to update the disk or filesystem boot code.

 Your deployment is starting, and the target machine is receiving your image it’s just generating an error when applying it.

Was the VM created by creating a fresh virtual machine, then capture/deploying that correct? It wasn’t converted from a physical -> virtual, correct? We do see that error if that was the case.

 According to your log, you’re deploying Windows 10 to a Latitude 7480. Ensure the target machine’s BIOS is set to the following:

 General
-Boot Sequence = UEFI
-Advanced Boot Options = Enable Legacy Option ROMs (not checked)
Secure Boot
-Secure Boot Enable = Enabled

 There is one other thing that you'll want to check. On certain Dell devices, one-time the boot menu (which appears if you press F12) will give you multiple options to boot the USB either in UEFI or legacy mode. This can be confusing when you look at it, because it doesn't always give the same name to each item in the boot list – one might say "USB flash drive" or "Removable disk", whereas the other might say "UEFI: [the specific brand name of the USB stick]".

If you've configured the BIOS settings as they appear above, then you will need to make sure to select the "UEFI" option for the USB stick in the F12 boot menu. You can confirm this once you are booted into the SmartDeploy PE environment, but looking in the lower right corner. You will see "Boot method", followed by either "BIOS" or "UEFI". Make sure that it is UEFI.

Thanks,

SmartDeploy Support

Share this post


Link to post
Share on other sites

We're running into the same issue with our HP Elitebook 840 G2.   We've disabled Secure Boot and Enabled Legacy mode.  Deployments are being done via WDS and systems are booting via PXE.

 

Share this post


Link to post
Share on other sites

Thanks for responding.  Will check the BIOS setting tomorrow.  I should note, however that we are booting via WDS PXE, not USB.

Also to answer your question about image creation, I captured it from a blank VDI created by Virtual Box using the Smart Deploy "Activities " menu.  No changes were made to the VDI after creating a local account and logging in.

Share this post


Link to post
Share on other sites
17 hours ago, SmartDeploySupport said:

 

So I did some testing this morning, and this still does not work.  When booting in UEFI mode, we are not given the option to PXE boot.  This is only available to legacy boot options.  Please advise

Share this post


Link to post
Share on other sites

Update 2

Changed BIOS settings as follows:

 

Boot Sequence:

Onboard NIC (IPV4) ENABLED
Boot List Option:  UEFI ENABLED

Advanced Boot Options:

Enable Legacy Option ROMs DISABLED / UNCHECKED

Secure Boot Enable:  ENABLED

 

Still nothing works.  Get the same error:  unable to update the disk or filesystem boot code

Share this post


Link to post
Share on other sites

I am also having trouble using smart deploy on a latitude 7480, one smart deploy boots in legacy mode from pxe, i cannot select anything and there is no mouse control

Share this post


Link to post
Share on other sites

turned out the platform pack was corrupt and deleted and re-downloaded it and it is working now

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now