Jump to content
DeployCentral
ACSATech

Answer File does not seem to be mapping drive or Image Source

Recommended Posts

So I am still in the process of setting up smart deploy with our systems with wds. In the meantime I am using USB to boot to Smart Deploy. 

I have a total of 3 images in one .wim file. I would like to set up a usb drive to boot to Smartdeploy and show the image selection screen and nothing else. I would like to skip every screen except the one where you choose your image. 

Even if I put the image in the answer file when I do boot to smart deploy the image is blank and I have to map to it using a UNC path. I have attatched the answer file here. I have even tried to map the unc path using a startup script and it doesn't map. Any help would be appreciated 

SmartDeploy.xml

Share this post


Link to post
Share on other sites

Hi there,

Thanks for reaching out. This behavior is definitely not expected - assuming you've supplied a valid UNC path and set of credentials, the image path and name (and description, if present) should be populated in those fields, and - since this is a multi-image WIM file, you would then have the option of selecting one of the other images from the dropdown.

Assuming that - when this occurs - you are able to manually map the network drive and continue with the deployment, this most likely indicates that you simply made a typo when saving the credentials in the Answer File Wizard. Credentials are hashed and salted in the Answer File exactly as entered (they are not validated at that time), so any typos at this stage will result in the behavior that you describe - a failure to automatically map the network drive and select the image, but no issues with network connectivity otherwise, and you are able to proceed with mapping the drive and selecting the image manually.

To resolve the issue, right-click the answer file in the Answer File Library, and click Edit. Then re-save the answer file, either overwriting the answer file or saving a new one (safer option), carefully re-entering the credentials when prompted. Note that you will need to edit the newly saved answer file in Notepad and set the Skip values to "1" (for each page that you wish to skip) as you did before. Then recreate your media and retry deployment.

Feel free to reach out by email if the issue persists - you can reach us at support (at) smartdeploy.com, and be sure to  reference this thread.

Regards,
Glenn

 

SmartDeploy Support Team

 

TECH RESOURCES

SmartDeploy User Guides

DeployCentral Forum

Platform Pack RSS

 

SOCIAL

SpiceworksTwitterfacebookyoutube

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×